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Introduction 
What is Everyware? 
You must have secure, remote access to current company data. You also need to share essential 
files with clients or colleagues without using insecure email or floppy disks. And these files must 
be backed-up securely. Your solution is Everyware. 
 
Away from the office, Everyware allows you secure data access and controlled collaboration 
from almost any Internet-enabled device. All files are encrypted and compressed using state-of-
the-art technology. Plus you have the ‘Exit Without A Trace’ option to erase all record of your 
transactions when using a remote workstation. 
 
With Everyware you get automatic backup to your server of all files that you create or change on 
any remote computer. Only newly created or changed files get backed up, and complex 
algorithms in the Everyware software ensure that only the changes to changed files are 
compressed and securely transferred, making Everyware the most efficient way to protect and 
access your valuable data. 

System Requirements 
The Everyware Server application can be run on the following minimum computer 
configuration:  
 

• Windows NT Workstation or Server 4.0 with Service Pack 4 or later (Server 
recommended).  

• Windows 2000 Pro or Server (Server recommended). 
• Pentium II 300 or better (PIII 500 recommended). 
• 128 MB RAM (256Mb recommended). 
• 50 Mb free disk space (for program files only). 
• Internet Explorer 4.0 SP1 or higher. 

 
The Everyware Client application can be run on the following minimum computer configuration: 
 

• Windows NT 4.0 with Service Pack 4 or later. 
• Windows 98, Windows 2000, or Windows XP. 
• Pentium 233 or higher (PIII 500 recommended). 
• 64Mb RAM (128 recommended). 
• 20Mb Disk space (for program files only). 
• Internet Explorer 4.0 SP1 or higher. 

 
If you are installing the software on a Windows NT machine, you must install Internet Explorer 
4.01, Service Pack 1 or later. Do NOT select Active Desktop when installing Internet Explorer 4. 
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Running the Everyware Server Administrator Application 
 
You can execute the Everyware Server Administrator application from the Windows Start menu 
by choosing Programs/Everyware. The application’s Main window appears: 
 

 
Figure 1: Everyware Server Administrator's Main Window 

 

Understanding the Everyware Server Administrator’s Main Window 
 
When the Everyware Server Administrator application’s window appears, you can choose to 
view user or account information. The Main window shows a menu bar and a working area 
filled with user, disk, or account data, depending on your current view mode. 
 
The menu bar on the Main window displays three menus: File, View and Help. Clicking one of 
these menus displays a list of menu commands, as follows: 
 
The File Menu 
Click the File menu item to see the File menu, shown here: 
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Figure 2: The File Menu 

The File menu contains four menu commands, as follows: 
 
Add Mount Point Lets you add an Everyware Server storage point. 
 
Add User  Lets you create an Everyware user account. 
 
Port Number Lets you change the TCP/IP port on which the server service runs. The 

default port is 80. The Everyware server software uses port 80 to connect 
with clients. If the Everyware Server software is installed on a computer 
that has additional third-party software using port 80 (for example, 
Internet Information Server), the Everyware server will NOT be able to 
connect with its clients. You can, however, configure the Everyware 
Server to use a different port. To do so, use the Everyware Administrator 
application by selecting Server Access from the File menu. If a port other 
than 80 is to be used, you must perform this configuration before starting 
the Everyware Server 

 
Logging Level Adjust the logging detail of the Everyware Server Administrator 

application 
 
Disk Usage View the disk usage of the user/disk.  Also generate a report of the disk 

usage. 
 
Exit   Terminates (or exits) the Everyware Server Administrator application. 
 
The View Menu 
Click the View menu item to see the View menu, shown here: 
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Figure 3: The View Menu 

The View menu contains four commands: Users, Disks, and Mounts. 
 
Users  Displays the Users window that lets you manage user accounts. 
 
Disks  Displays the Disks window that lets you manage user disks. 
 
Mounts Displays the Mounts window that lets you view the Everyware server disks. 
 
 
 
The Help Menu 
Click the Help menu item to see the Help menu, shown here: 
 
 

 
Figure 4: The Help Menu 

The Help menu contains a single menu item – About Everyware. An About dialog box appears 
showing information about the application itself. 
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Managing User Accounts 
Working with User Accounts 
You can add, delete, and modify user accounts in the Everyware Server Administrator 
application. To open the Users window, choose Users from the Administrator Main window. 
The User window appears: 
 

 
Figure 5: Users Window 

The Administrator can advance through the database of users by pressing the forward/previous 
buttons or selecting the browse button and selecting a user from a list.  For each user, the 
window shows the user’s alias ID, name, email address, real name, status, and disks shared. 
  
When you create an account, you can assign an alias as well as the user’s real name. You might, 
for example, create a user whose alias name is Tester and whose real name is Jack Smith. 
 
A user account may have a status of either Active or Inactive. The Disks Count column shows 
how many virtual hard disks (VHDs) are assigned to this user account. 
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Adding a User Account 
You can add a user account to the Everyware Server Administrator application by clicking the 
File menu and choosing Add User, or selecting New of the user window, or selecting  of the 
toolbar.  The Add User window appears: 
 

 
Figure 6: Add User Window 

In the Name field, type the name you want to assign to this user account. Type the password for 
the user account. The Disk Name is the name you will see in the Everyware Client application’s 
window. Next, type a valid email address and the user’s real name. 
 
If this account is to be synchronized with the server, select the Active check box. Inactive 
accounts are not synchronized with the server. 
 
Select the Higher Security check box if a higher encryption level is to be used for data transfers 
associated with this disk. 
 
To select a Custom Server path, select this check box. A custom server path must be a valid 
name for an existing directory, such as D:\Shares\Users|Tester. Click the Browse button to 
search for an appropriate directory. 
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► To add a user account: 
1. Double click on the User icon, of the Administrator Main window, and choose New 

or click on  toolbar item of the Main Window. 
2. Type an alias name for this user in the Name field. 
3. In the Password field, type a password for this user. Type the password a second time 

in the Password (Confirm) field to verify it. 
4. In the Disk Name field, type the name you will see in the Everyware Client 

application. 
5. Type the user’s email address in the Email field (Optional). 
6. In the Real Name field, type the user’s real name (Optional). 
7. If this user’s file should be synchronized, select the Active box. 
8. If high encryption for file transfers should be used, select the Higher Security? box. 
9. If you want to select a specific path, select the Custom Server Path? box and type (or 

Browse for) the path in the Custom Path field. 
10. Click OK. 

 

Assigning a Secondary Disk to an Account 
You can assign a secondary disk drive to a user account by clicking on the New Disk button of 
the User window.  A secondary disk can also be added by double-clicking on the Disk icon, of 
the Administrator main window, and clicking on the New Disk. 
 
The Add Secondary Drive window appears: 
 

 
Figure 7: Add Secondary Drive Dialog Box 

The Owner field contains the name of the owner (user). In the Disk Name field, type the name 
for this disk drive. This disk drive name appears in the Everyware Client application’s window. 
 
If you want to use a higher encryption level for data transfers associated with this disk, select the 
Higher Security? check box. 
 
To specify a custom server path to the disk, select the Custom Server Path? check box. You can 
specify any valid path to an already created directory (for example, d:\shares\users\tester). To 
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find an appropriate directory, you can click the Browse button to select an appropriate path for 
this field. 
 

► To assign a secondary disk to this user account: 
1. Select the user account in the Users window and choose New disk. 
2. Owner is defaulted (grayed out) to the current user. 
3. In the Disk Name field, type a name for this drive. 
4. If high encryption for file transfers should be used, select the Higher Security? box. 
5. If you want to select a specific path, select the Custom Server Path? box and type (or 

Browse for) the path. 
6. Click OK. 
 

► To assign a secondary disk to any user: 
1. Select the New Disk from the Disks window. 
2. Select the Owner for this drive. 
3. In the Disk Name field, type a name for this drive. 
4. If high encryption for file transfers should be used, select the Higher Security? box. 
5. If you want to select a specific path, select the Custom Server Path? box and type (or 

Browse for) the path. 
6. Click OK. 

 

Updating a User Account 
To make changes to an existing user account, select the user account of the User window and 
choose Update. The Update User window appears: 
 

 
Figure 8: Update User Window 
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The Update User window shows the user’s alias name, password, email address, and real name. 
To change information, click the field and type the new information. The account’s password 
will not be visible (you’ll see asterisk characters instead) but you can type a new password for 
the user account. 
 
To set the account’s status as active, select the Active check box. An active account means the 
account can be synchronized with the server. 
 

► To modify/update a user account: 
1. Select the user account in the Users window and choose Update (top right button). 
2. Edit the information shown in the window. 
3. Click OK. 
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Managing Virtual Disk Drives 
Working with Disk Accounts 
You can add, delete, and modify disk accounts in the Everyware Server Administrator 
application. To open the Disks window, choose Disks from the Views menu or double click on 
the Disks icon for the main window. The Disks window appears: 
 

 
Figure 6: Disks Window 

The Disks window lists the user disk accounts you have created. For each disk, the window 
shows the disk’s name, the owning account’s name, the disk’s security level, path, and the 
number of users sharing the disk. 
 
The name shown in the Disk Name column is the name of the disk. This is the default directory’s 
name the user disk root is created in on the client computer when it was first used. 
 
The Path column shows the physical location of the disk on the server. 
  
The Shared # column displays the number of user accounts this disk is shared with. This count 
does not include the owner. 
 
You can perform commands on a disk account by selecting a disk account in the Disks window 
and choosing New Disk, Update Disk, Modify Shares, Permissions, and Remove Disk. 
 

 

 

Everyware Solutions Inc.  13 



Everyware Server-Side User’s Guide 
 

Adding New Disk 
The New Disk window lets you add a new disk. To add a new disk, choose New Disk from the 
disk window. The New Disk window appears: 
 

 
Figure 7: New Disk Window 

The New Disk window shows a list of valid users as owners. Custom Path is available if the 
drive needs to be in a custom location. 
 

► New disk for any user: 
1. Select the New Disk from the Disks window. 
2. Select the Owner for this drive. 
3. In the Disk Name field, type a name for this drive. 
4. If high encryption for file transfers should be used, select the Higher Security? box. 
5. If you want to select a specific path, select the Custom Server Path? box and type (or 

Browse for) the path. 
6. Click OK. 

 

Updating The Disk 
The Update Disk window lets you change the owner, name, security, and custom path of the 
selected disk. To update/change the disk, left-click the disk account in the Disks window and 
choose Update Disk. The Update Disk window appears: 
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Figure 8: Update Disk Window 

The Update Disk window shows a list of valid users as owners. Custom Path is grayed out if the 
disk didn’t set a custom path previously. 
 

► To update disk: 
1. Select the disk account in the Disks window and choose Update Disk. 
2. Update the disk information. Specify a new owner, disk name or level of security for 

the disk. 
3. Click OK. 

 

Sharing Disks Amongst Users 
You can share a disk amongst many users.  To modify sharing left-click the disk account in the 
Disks window and choose Modify Share. The Change Sharers window appears: 
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Figure 9: Change Sharers Window 

The Change Sharers window shows a list of non-sharers and sharers. Select a user’s name and 
then click the >> or << button to modify the sharing privileges. 
 

► To change a disk’s sharing privileges: 
1. Select the disk account in the Disks window and choose Modify Shares. 
2. Select a user in the Non Sharers or Sharers box and click the > or < button. 
3. Click OK. 

 

Viewing and Modifying Disk Sharers 
You may view the type of access users have for shared disks. To do so, left-click the disk 
account in the Disks window and press the Permissions button. The Disk Sharers window 
appears: 
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Figure 10: Disk Sharers Window 

The Disk Sharers window shows the user’s name and whether the user has Put and Delete 
privileges. You can double-click the item to change the privilege between Yes and No. 
 

► To view/modify disk sharers: 
1. Select the disk account in the Disks window and choose Permissions. 
2. Choose Sharers from the pop-up menu. The Disk Sharers window appears. 
3. To modify the account, double-click the column to toggle. 
4. Click OK. 

 

Deleting a Disk Account 
A disk account may be removed at any time. To delete a disk account, select the account and 
press the Remove Disk. A confirmation window appears. Click OK to delete the account. 
 

 
 
 

► To delete a disk account: 
1. Select the disk account in the Disks window and chose Remove Disk. 
2. Click OK to confirm the delete request. 

 

Setting Security Levels for Disk Accounts 
A disk account may have normal or high security level.  

► To set a disk’s security level: 

Everyware Solutions Inc.  17 



Everyware Server-Side User’s Guide 
 

1. Double click the disk account in the Disk window or select the disk account and 
choose Update Disk. 

2. Check Higher Security? For encryption or uncheck to apply normal security. 
3. Click OK. 

 

Usage Report 
Usage Report is an administrative tool that easily shows the combined disk usage of a particular 
user.  Reports can be generated for 1) the current user 2) all active users 3) all users.  The report 
can either be saved to a specified file or sent via email. It can be opened by double-clicking the 
Usage Report icon in the main window or clicking on the Usage Report of the File menu.  The 
Usage Report window is shown here: 
 

 
Figure 11: Usage Window 

 
The Administrator can advance through the database of users to view the usage for a particular 
user.  The Administrator can also click on the browse button and quickly select the user to view 
usage. 
 
Usage reports can be generated and saved onto a file or sent via email. 

Everyware Solutions Inc.  18 



Everyware Server-Side User’s Guide 
 

Generate Usage Report File 
The report generated is a text file with comma-delimited fields.  The report can be imported into 
Excel or any other spreadsheet (comma delimited field enabled) to better view the disk usage. 
 

► To generate a usage report and save to file: 
1. From the Usage Report window select the type of report to be generated whether the 

report should only be the current user, only the active users, or all users. 
2. Press the File button and specify the name and location to save the file. 
3. Click OK. 

Generate Usage Report Send Via Email 
The report is sent via email and is attached as a text file with comma-delimited fields.    The 
report can be imported into Excel or any other spreadsheet (comma delimited field enabled) to 
better view the disk usage. 
 

► To generate a usage report and send via email: 
1. From the Usage Report window select the type of report to be generated whether the 

report should only be the current user, only the active users, or all the users. 
2. Enter the values for the To, From, and Mail Server.  
3. Press the Email button to send. 
4. Click OK. 
 

Managing Mount Accounts 
A mount is a directory the Everyware server uses as a data store. In most cases, mounts are on 
separate hard disks. You can use the Mounts window to manage your mounts. The Mounts 
window is shown here: 
 

 
Figure 12: Mounts Window 
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For each mount, the Mounts window shows the path, identifier, default location, and disk count. 
The mount’s path is the directory that stores the data store. This path can be in a standard DOS or 
Windows driveletter:path format or a Universal Naming Convention (UNC) 
\\servername\sharename format for network resources. 
 
Each mount is assigned a unique identifier. The identifier is a number the Everyware server 
software generates automatically. 
 
The Default column specifies whether the path is the location where new data stores are created. 
You can change this status field by double-clicking directly on the field. 
 
The Disk Count column shows how many disks are on this mount. 
 

Changing the Default Mount 
You can change the default mount. To do so, right-click the selected mount in the Mounts 
window and select Default Mount. When you select this command, the select mount is set as the 
default. 
 

► To set a mount as the default mount: 
1. Select the mount in the Mounts window list. 
2. Press Set Mount button. 

 

Adding A Mount 
To add a mount, choose New Mount from the Mount window. The New Mount Point window 
appears: 
 

 
Figure 13: Add Mount Point Window 

Specify a path in the Mount Point field and click OK to create the mount. 
 

► To add a mount: 
1. From the Mount window, choose New Mount. The New Mount Point window 

appears. 
2. In the Mount Point field, type a path or click Browse to find a path. 
3. Click OK. 
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Deleting a Mount 
At any time you may delete a mount. To delete a mount, the selected count mount in the Mounts 
window and select Delete Mount. A confirmation window appears. Click OK to confirm that you 
want to delete this mount. 
 

► To delete a mount: 
1. Select the mount account in the Mount window 
2. Press Delete Mount button. 
3. Click OK to confirm the delete request. 

 

Renaming a Mount 
You can rename a mount.  

 
Figure 22: Rename Mount Point Window 

 
► To rename a mount: 

1. Select the mount in the Mount window list 
2. Press Rename Mount button.  The Rename Mount window appears. 
3. Click OK to confirm the rename request. 
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Getting Help and Product Support 
The Help Menu 
While using the Everyware Server Administrator application, you can view information about 
the application itself. To view the About information, select the Help menu item and then 
choose About Everyware Admin. 
 

 
Figure 14: Help Menu 

Troubleshooting Guide 
The following is a list of frequently asked questions. Should you need more information, please 
contact customer support. 
 
 
When I start the Everyware Administrator application and open the user, disk, or mount 
view (window), I receive a “can not connect to MDPS database” error message. 
 
When I use the Everyware Client to synchronize with the Everyware server, I receive an 
“unable to get a list of boxes” error. 
 
These two situations may occur when the database has not shut down or started correctly. To 
verify if this is causing your error condition to occur, type the following in a DOS command 
prompt window: 
 “ps –ef” 
A list of active processes like those shown here appears: 
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If you do not see an entry in the form /usr/bin/postgress, the database is not running and will 
need to be started. To start the database, open the services control penal applet and stop the 
postgres service. When the service has stopped,, open Windows Explorer and navigate to the 
directory:C:\Program Files \ ATP \ Everyware \ Server \ cygwin \ Everyware and delete the 
postmaster.pid file.  Start the postgres service in the services control panel applet. 
 
I get a “failed to connect to server” error message in the Everyware client when trying to 
synchronize with the Everyware server. 
 
This message most likely is caused by the Everyware server service being stopped.  To correct 
this problem, open the Services control panel applet and start the Everyware service. 
 
 

Product Support 
If you require further assistance with any Everyware product, visit our website at 
http://www.everywaresolutions.com/. Use the Product Support Key provided by your System 
Administrator to access the support information you require. For toll-free, registered support, 
please call our customer support team at 1-866-273-8376. 
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